Email Delivery Degraded

Resolved
Duration: 11mAug 27, 2026

Affected services

Email Deliverability

Partial outage

Timeline

Resolved
22:10Aug 27, 202619d ago

The issue affecting email delivery has now been resolved, and email sending has returned to normal - this was affected for approximately 10 minutes impacting emails from Culverdocs.

If you were expecting an email during this time and it hasn't arrived - for example a password reset or workflow report - please request/reprocess it again. If you're still missing an email or have any questions, please contact our support team and we're here to help.

Our apologies for the inconvenience.

Investigating
21:58Aug 27, 202619d ago

We are currently aware of an issue at our third party email provider which is currently causing delays and failures for some to emails being delivered from Culverdocs. This is being monitored and we will update as soon as possible. Our apologies for the inconvenience and if you have any queries please contact support.

Email Deliverability